scalaインストール時に苦戦したのでメモ

scalaをubuntu14.04にインストールし、実行しようとしたら以下のようなエラーが発生。

error: error while loading CharSequence, class file '/usr/lib/jvm/java-8-oracle/jre/lib/rt.jar(java/lang/CharSequence.class)' is broken
(bad constant pool tag 18 at byte 10)

解決方法

端末などから

sudo update-alternatives --config java

使用可能なjava一覧が表示される。

ここからscalaが使用できるようなjavaのバージョンを選択する。

現在はjava 8が良いらしい。