技術系メモ

雑多なメモです。ほんと自分用のwikiです。

ubuntuを15.04でapt-get updateするときのエラーの対処法

以下のようなエラーが発生

W: http://dl.google.com/linux/webdesiner/deb/dists/stable/Release の取得に失敗しました
 期待されるエントリ 'main/binary-i386/Packages' が Release ファイル内に見つかりません
 (誤った sources.list エントリか、壊れたファイル)

E: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、
古いものが代わりに使われます。

対処法

端末で以下のコマンドを実行する

 sudo gedit /etc/apt/sources.list.d/google-webdesiner.list 

ファイルに[arch=amd64]を付け加える。具体的には以下のように

 deb [arch=amd64] http://dl.google.com/linux/webdesiner/deb/ stable main

そして、もう一度以下のコマンドを実行すれば、うまくいくはず

sudo apt-get update