技術系メモ

雑多なメモです。ほんと自分用のwikiです。

undefined method `[]' for Matrix:Module

railsや自作gemを作成するときにMatrixを使うときの注意。

エラー内容

タイトル通り

undefined method `[]' for Matrix:Module

原因

Gemfileに

gem 'matrix'

と書いてbundle install してしまうとタイトルのようなエラーが出る模様。(matrix 0.0.1っていう古いバージョンがインストールされてしまうみたい)

対処法

Gemfileから

gem 'matrix'

を消す。matrixはすでにrubyのライブラリのデフォルトになってるらしいので、 bundle install しなくても使える