技術系メモ

メモ。内容は保証しません。

【python】【pygame】pygameのインストールでのエラー

環境

ubuntu 16.04

python 3.4

問題

pip install pygame 

<省略>
Hunting dependencies...

WARNING: "sdl-config" failed!

WARNING: "freetype-config" failed!

Unable to run "sdl-config". Please make sure a development version of SDL is installed.

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip_build_okano/pygame
Storing debug log for failure in /home/okano/.pip/pip.log

対処(暫定)

以下の手順でとりあえず動いた

sudo apt-get build-dep python-pygame
sudo apt-get install python-dev
pip install -U pip setuptools```
pip install pygame